Applying WebLogic 10.3.6.0 PSU and patch conflicts!

Applying
latest PSU
?Patch Set Update? for latest bug fixes and security vulnerabilities,
(PSU
October 2016
?
Patch
ID:
K25M
Patch
No:
23743997
To
find the relevant patch number.:
1.
Checked the
Critical Patch Updates, Security Alerts and
Third Party Bulletin
3.
Looked for “Oracle WebLogic Server” and clicked on
Fusion Middleware next to the product
4.
Searched for “WebLogic Server
10.3.6.0”.

Then
download the patch from MOS
Also
refer following MOS note.
Oracle E-Business Suite Release 12 Critical Patch
Update Knowledge Document (October 2016) (Doc ID 2181748.1)
Set
your environment:
cd $FMW_HOME
 cd wlserver_10.3/server/bin
.  ./setWLSEnv.sh
Verify the patch applied or not
bsu.sh
-prod_dir=$FMW_HOME/wlserver_10.3 -status=applied -verbose -view | grep -i 
K25M
Unzip
the patch to the cache_dir directory:
cd $FMW_HOME/utils/bsu/cache_dir
cp /oracle/software/ p23743997_1036_Generic.zip
$FMW_HOME/utils/bsu/cache_dir
unzip p23743997_1036_Generic.zip
Stop all WebLogic servers
Install
the patch using the Smart Update command utility:
cd $FMW_HOME/utils/bsu
./bsu.sh ?install ?patch_download_dir=$FMW_HOME/utils/bsu/cache_dir
?patchlist=K25M ?prod_dir=$FMW_HOME/wlserver_10.3
Patch Conflicts detected
Conflict condition details follow: 

Patch K25M is mutually exclusive and cannot
coexist with patch(es): HSZB,Z62H,5C71,7Z9S,DEM4

This
means that the new PSU patch is conflicting with the other patches listed
above, so I have 3 options here:
1.
Forget about the latest PSU patch and leave– not recommended.
2.
Request an “overlay” patch from Oracle Support which effectively merges all of
the patches
?if some patches listed
above aren’t included
in
the new PSU
?.
3.
If the new PSU contains all of the above patches, remove them first, then apply
the new PSU.
Capture
patches installed
cd $FMW_HOME/utils/bsu
/bsu.sh
-prod_dir=$FMW_Home/wlserver_10.3 -status=applied -view -verbose >
/tmp/bsu_patches_installed.log
Remove
patches
cd $
FMW_Home/utils/bsu
The below
patches are Oracle WebLogic Sever overlay patch for PSU 10.3.6.0.160419. We  need to remove these following patches in order to apply
the latest PSU.
 HSZB,Z62H,5C71,7Z9S,DEM4
./bsu.sh
-prod_dir= $FMW_Home /wlserver_10.3  -patchlist= <Patch ID> -verbose -remove
Now  Install 
the patch.

cd $
FMW_Home/utils/bsu

bsu.sh
-install -patch_download_dir=$FMW_HOME/utils/bsu/cache_dir  -patchlist=K25M -prod_dir=$WLS_HOME
  
cd  $FMW_HOME/wlserver_10.3/server/bin
.  ./setWLSEnv.sh
 java weblogic.version|grep PSU
WebLogic
Server 10.3.6.0.161018 PSU Patch for BUG23743997 TUE AUG 30 18:34:42 IST 2016
That’s
it, WebLogic is installed and patched up-to-date.
For more
details on WebLogic PSU conflicts, following  are  good MOS notes.
Announcing
Oracle WebLogic Server PSUs (Patch Set Updates) [ID 1306505.1]
Replacement
Patches for WebLogic Server PSU Conflict Resolution [ID 1471192.1]
Happy
learning !!

  • December 29, 2016 | 21 views
  • Comments