Error while running autoconfig in DB Tier

                                        Error while running autoconfig in DB Tier



Error:
UnsatisfiedLinkError exception loading
native library: njni11

UnsatisfiedLinkError
exception loading native library: njni11 while running Autoconfig on DB Node



After upgrading database to 11GR2, This issue can occur.

While running autoconfig on the DB node this error occured.

java.lang.UnsatisfiedLinkError: /u01/CRP1/db/tech_st/11.2.0/lib/libnjni11.so:
/u01/2CRP1/db/tech_st/11.2.0/lib/libnjni11.so: wrong ELF class: ELFCLASS64
(Possible cause: architecture word width mismatch)

Solution :

To fix this issue, Edit the database
node xml as below and re-run the autoconfig.

From
—-
<          <JDK_TOP
oa_var=”s_jdktop”>/u01/CRP1/db/tech_st/11.2.0/appsutil/jre</JDK_TOP>
<          <JRE_TOP
oa_var=”s_jretop”>/u01/R12CRP1/db/tech_st/11.2.0/appsutil/jre</JRE_TOP>

To

>          <JDK_TOP
oa_var=”s_jdktop”>/u01/CRP1/db/tech_st/11.2.0/jdk/jre</JDK_TOP>
>          <JRE_TOP
oa_var=”s_jretop”>/u01/CRP1/db/tech_st/11.2.0/jdk/jre</JRE_TOP>




Note:
—-
From 11gR2 DB version onwards AutoConfig on DB node uses the JRE from <Oracle_Home>/jdk/jre where as earlier versions of DB uses JRE from $ORACLE_HOME/appsutil/jre

  • September 12, 2016 | 13 views
  • Comments