OPatch Failed with Error Code 19 – “The OPatch version is not applicable for current OUI version”

ISSUE:

While trying to apply a patch on a Fusion Middleware or WebLogic Server Oracle home, the following error occurs:

$ ./opatch lsinventory -jre /usr/java/jdk1.8.0_141/jre

OPatch Version : 13.9.0.0.0
OUI Version : 12.1.0.2.0
The OPatch version is not applicable for current OUI version.

Since OUI Version starts with 12.1, Please go to ‘My Oracle Support’ and get right OPatch 12.1.*.*.* based on patch 6880880, release version 12.1.0.0.0 and appropriate platform.

OPatch failed with error code 19

CAUSE:

As the error states, OUI and OPatch version do not match.

Upon further investigation, it is observed that the ORACLE_HOME is not set correctly and pulling a different OUI version from another environment.

SOLUTION:

1. Set ORACLE_HOME to the directory being patches. Also look at the PATH environment variable to ensure you don’t have the OPatch directory from another location. The following should always be set before running opatch commands:

UNIX:
ORACLE_HOME=$MW_HOME/Oracle_FRHome1; export ORACLE_HOME
PATH=$ORACLE_HOME/OPatch:$PATH; export PATH

Windows:
set ORACLE_HOME=%MW_HOME%OHS
set PATH=%ORACLE_HOME%OPatch;%PATH%

2. Now you should be able to invoke the “opatch lsinventory” see the correct opatch version and intended Oracle home. Then run the “opatch apply” command to apply the patch.

Note: The error says, “get right OPatch 12.1.*.*.* based on patch 6880880”, this is actually referring to an Oracle Database version. For Oracle Fusion Middleware, it is very rare to need to update OPatch or use Patch 6880880 to obtain a new one. Always use the one installed in the Oracle home or a backup if accidental overwritten with another version. Problems will occur if the incorrect Opatch is installed

Reference:

OPatch Failed with Error Code 19 – “The OPatch version is not applicable for current OUI version” (Doc ID 2364024.1)

  • June 28, 2019 | 26 views
  • Comments